CA Performance Center upgrade fails due to home path disk space being full

Document ID : KB000113237
Last Modified Date : 06/09/2018
Show Technical Document Details
Issue:
During an upgrade for CA Performance Center (CAPC) the install home path, /opt, ran out of disk space.

Disk space was added during the install run to allow it to complete, but it didn't complete successfully. How can we resolve the errors from the disk space problem?

This is the specific error observed in both the mysql *.err log and Performance_Center_Install*.log files

Execute Custom Code 
class com.ca.im.installanywhere.action.MigrateDb FatalInstallException DbMigrate threw an exception: java.sql.SQLException: Error executing command: CALL item_grouppath_tables() on line 245 in script /opt/CA/PerformanceCenter/EM/SQL/upgrade/3.6.0.0/update_grouppath_tables.sql The table '#sql-2520_e' is full 
Passed services 
Environment:
All supported CA Performance Management releases
Cause:
Disk space filled in /opt, the install home for CAPC. This happened during the upgrade of the MySql em Database for Event Manager causing the install to fail.
Resolution:
Run the following: 

./npcshell.sh dbmigrate -xmlMigrateFile ../../EM/SQL/_em_upgrade.xml 

Validate release is updated with: 
select * from revision_info order by InstallDate desc; 

Restart Event Manager services and it should function normally.