CA IDMS gives error DC265911 V10 QUEUE <queue-name> NOT FOUND. Why?

Document ID : KB000004570
Last Modified Date : 14/02/2018
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Issue:

The command "DCMT DIS QUEUE *ALL" produces a list of queues. One of these is specified in a delete command using this syntax:    

DCMT VARY QUEUE <queue-name> DELETE 

This gets error below, even though the first command shows that the queue exists.
DC265911 V10 QUEUE CCCP974PCL NOT FOUND 

 

Why?

Environment:
This can occur in any CA IDMS environment on any operating system, whether issued online or using UCFBTCH.
Cause:

1- The DCMT D QUEUE *ALL shows all QUEUEs that currently exist in the DDLDCRUN area plus any QUEUEs defined in sysgen, regardless of whether they currently exist in DDLDCRUN. 

2- The DCMT D QUEUE *ALL as well as the DCMT D QUEUE CCCP974PCL tell us the current record count for this queue is 0000.

3- When a queue count is 0, it does not exist in the DDLDCRUN; it only exists as a definition in the sysgen. 

4-The DELETE command only deletes queue records that exist in the DDLDCRUN area. Since this queue has a count of 0, there is nothing to delete from that area and the command will find nothing to delete.

Resolution:

The error message is correct; there is nothing to delete in this case. No action is necessary. As stated in the CA IDMS System Tasks and Operator Commands manual, the DELETE parameter on the DCMT VARY QUEUE statement "Deletes the named queue from the queue area. DELETE has no effect of queues defined at system generation time and stored in the data dictionary."

 

Additional Information:

Details about the DCMT DIS QUEUE command can be found here: https://docops.ca.com/ca-idms-ref/19/en/ca-idms-system-tasks-and-operator-commands/dcmt-display-commands/dcmt-display-queue-command

Details about the DCMT VARY QUEUE DELETE command can be found here: https://docops.ca.com/ca-idms-ref/19/en/ca-idms-system-tasks-and-operator-commands/dcmt-vary-commands/dcmt-vary-queue