CA Identity Portal 14.1 fail to start

Document ID : KB000094164
Last Modified Date : 03/05/2018
Show Technical Document Details
Issue:
The CA Identity Portal installation fails to start with error that related to table or view does not exist
Environment:
IP 14.1 
Cause:
This is due to DB user did not have correct privilege
Resolution:
Grant user (e,g IAM_UI) the following privilege

CREATE USER IAM_UI 
IDENTIFIED BY <password> 
DEFAULT TABLESPACE IAMPRVS_DS 
TEMPORARY TABLESPACE TEMP 
PROFILE DEFAULT 
ACCOUNT UNLOCK; 
-- 4 Roles for IAM_UI 
--GRANT SCHEMA_OWNER_SYSPRIV TO IAM_UI; 
GRANT CONNECT TO IAM_UI; 
GRANT RESOURCE TO IAM_UI; 
-- ALTER USER IAM_UI DEFAULT ROLE ALL; 
-- 9 System Privileges for IAM_UI 
GRANT CREATE TABLE TO IAM_UI; 
GRANT UNLIMITED TABLESPACE TO IAM_UI; 
--GRANT DROP TABLESPACE TO IAM_UI; 
GRANT CREATE VIEW TO IAM_UI; 
--GRANT MANAGE TABLESPACE TO IAM_UI; 
--GRANT CREATE TABLESPACE TO IAM_UI; 
--GRANT CREATE TRIGGER TO IAM_UI; 
GRANT CREATE SESSION TO IAM_UI; 
GRANT CREATE SEQUENCE TO IAM_UI; 
-- 4 Object Privileges for IAM_UI 
--GRANT SELECT ON SYS.DBA_2PC_PENDING TO IAM_UI; 
--GRANT SELECT ON SYS.DBA_PENDING_TRANSACTIONS TO IAM_UI; 
--GRANT EXECUTE ON SYS.DBMS_SYSTEM TO IAM_UI; 
--GRANT SELECT ON SYS.PENDING_TRANS$ TO IAM_UI;