CA Identity Manager: Workpoint database errors are preventing IM startup after an upgrade

Document ID : KB000098011
Last Modified Date : 06/06/2018
Show Technical Document Details
Issue:
When trying to boot up your Identity Manager server, the following error appears in the application server log: 

Error message = WorkItemPvt.query() returned com.workpoint.common.exception.WorkflowException. Error message = The WorkPoint database version should be '[version #]' for the WPDS DSN but is found to be not present in the WP_INI table for SECTION_NAME=Database and KEY_NAME=version. This may mean you are running against an incompatible or outdated WorkPoint database version. Please upgrade the WorkPoint database manually, or set the auto.db.create.or.upgrade property to true in the workpoint-server.properties file and restart the server. 
Resolution:
In the workpoint-server.properties file there is a setting called auto.db.create.or.upgrade. Set this property to true and restart the server. This allows the WP DB to upgrade itself.