CA Identity Manager fails to boot due to SCIM endpoint

Document ID : KB000008214
Last Modified Date : 14/02/2018
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Issue:

Upon upgrading the Identity Manager version from 12.6 SP3 to 12.6 SP7 we are experiencing a start up issue where the application server fails when it reaches step 5. 

10:41:29,192 INFO  [ims.Main] * Startup Step 5 : Attempting to start SecretKeyStore

Immediately after this an error appears with "Endpoint type [SCIM] has already been previously defined"

Environment:
12.6 SP7
Cause:

There are duplicate copies of the endpoint type [SCIM]

Resolution:

To resolve follow these steps:

1) Shut down the application server.

2) We need to delete the SCIM.jar files from the location listed in the log file.

Ex. it will contain the file path "war/WEB-INF/lib/SCIM.jar" Remove the jar from this location. (I would recommend backing it up or removing it from this location)

3) start up the application server. At this point it should continue past startup step 5.