CA Datacom SVC report shows ***** WARNING ***** THE ABOVE SVC DEFINITION IS NOT VALID FOR DATACOM/DB VERSION. Why?

Document ID : KB000023079
Last Modified Date : 14/02/2018
Show Technical Document Details

Question:

The CA Datacom SVC report produced by running the DBUTLTY batch utility with control statement REPORT MEMORY=MVS shows the following warning message only for the version 12.0 SVC (in this case, SVC 246) and also does not provide the expected SVC details:

 246    3/4            31  8BD44000  EC  12    08/08/09 16.27                
 ***** WARNING ***** THE ABOVE SVC DEFINITION IS NOT VALID FOR DATACOM/DB VERSION

Is this warning a concern?

Answer:

The SVC was successfully loaded, in this case via CAIRIM, as indicated by the success messages:

 CAS9075I - Service(CA-RIM/BASE ) Vers(V1.0) Genlvl(B008S9100)                
 CAS9111I - Violation message deferment threshold located in ESQA at 0243CEDC 
 CAS9115I - Input: PRODUCT(CA DATACOM) VERSION(BD12) INIT(DBRIMPR)            
 CAS9115I - Input: PARM(D246,DBSVCPR,TYP=3)                            
 DB90100I CA-DATACOM DBRIMPR     12   *, 04/29/0909.34                        
 DB90101I CA-DATACOM/DB SVC LOAD SUCCESSFUL                                   
 DB90120I CA-DATACOM/DB INITIALIZATION SUCCESSFUL                             
 CAS9130I - Module DBRIMPR  complete, RC=00

The warning occurred in the DBUTLTY SVC report because the version of the Datacom load library was not version 12.0 but was an earlier version 10.0. The CA Datacom SVC has changed over the releases and the Datacom version 10.0 library cannot be used to produce the SVC report. Also, the 12.0 SVC report format has changed to provide additional information. Details can be found in the CA Datacom/DB DBUTLTY Reference Guide for z/OS Version 12.0.00, Chapter 31: REPORT (Generate Reports) on REPORT MEMORY=MVS.

Additional Information:

Note that starting with Datacom Version 14.0, SVCs are no longer used. 

TEC607065 "When installing CA Datacom version 14.0, how do I set up CAIRIM to load the PC Calls when I also have version 12.0 SVCs in use?"

http://www.ca.com/us/support/ca-support-online/product-content/knowledgebase-articles/tec607065.aspx