CA APM upgrade over 2 steps does not update ws-plugins directory impacting Workstation usage

Document ID : KB000117151
Last Modified Date : 09/10/2018
Show Technical Document Details
Issue:
After upgrading MOM installation in 2 steps i.e. APM DB upgrade followed by Enterprise Manager/WebView upgrade when try to use the Workstation after successful authentication the expected UI does not display
Environment:
CA APM 9.x, 10.x
Upgrading any APM version to a later version.
The problem impacts both interactive and silent installs.
Cause:
The EM_HOME/ws-plugins directory contains jar files which did not get updated to the new version and the old files still remained. (NOTE: Other jar files under EM_HOME are updated to the new version correctly)
The ws-plugins directory is not being updated because the APM DB upgrade step updating the version info in file EM_HOME/UninstallerData/base/installvariables.properties . That change subsequently prevents the ws-plugins directory from being updated later during the MOM Enterprise Manager/WebView upgrade step.
Resolution:
Workaround:
Interactive install:

For the APM DB upgrade step choose an install directory which is different to the existing MOM EM install directory

Silent Install:
For the APM DB upgrade step set the silent install response file property USER_INSTALL_DIR to an install directory which is different to the existing MOM EM install directory

In that way the APM DB related logs and some files will be copied into the new install directory and the original EM directory will be untouched. That will prevent the updating of the version info in the file EM_HOME/UninstallerData/base/installvariables.properties and the MOM Enterprise Manager/WebView upgrade step will then update the ws-plugins directory correctly.
Additional Information:
Future Fix:
An internal User Story (US549582) has been created as an enhancement request for the APM Installer team to review and prioritize in a future release.