CA API Management: Unable to view all OAuth clients in OAuth manager

Document ID : KB000008008
Last Modified Date : 14/02/2018
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Issue:

When viewing clients in the OAuth manager you are unable to see all of the registered clients even when assigned an administrator role.

registered_by.png

 

user_properties.png

Cause:

By default there are only 3 user names that are considered as administrators in OAuth.

These are admin, pmadmin and administrator. User role assignment will not affect these permissions and any other accounts must be explicitly set in policy to be administrators.

 

Otherwise you will be restricted to only seeing clients that your ID has registered.

Resolution:

For OTK 3.x you will need to edit the 'OTK User Role Configuration'  policy.

For OTK 4.x you will need to edit the 'OTK User Attribute Look Up Extension'  policy.

 

1. Locate the following 'compare' assertion

compare.png

2. Edit the compare assertion to include the name of the user you wish to make an administrator separating each id with the pipe character

user_role_config.png

3. Save and Activate the policy