Bulk Load Client Fails TLS 1.2 HTTPS Connection With SSL Handshake Error

Document ID : KB000111191
Last Modified Date : 15/08/2018
Show Technical Document Details
Issue:
Attempting to use the Bulk Load Client to connect to Secure Cloud via HTTPS fails. The Bulk Load Client log shows SSL Handshake errors. The problem started happening on the evening of August 9, 2018.
Environment:
Secure Cloud
Cause:
Secure Cloud (US) was updated on August 9 to remove support for TLS 1.0 and TLS 1.1 protocols. The Bulk Load Client's imbulkloadclient.bat file by default points to the embedded JVM which is a Java 6 version (i.e. ..\_uninst\_jvm\bin\java) but Java 6 does not support TLS 1.2 protocol.
Resolution:
Install Java 8 and edit the Bulk Load Client's imbulkloadclient.bat file to instead use the Java 8 version of java.exe which support TLS 1.2 protocol.