Build Tool warning; 'includeantruntime' was not set

Document ID : KB000013178
Last Modified Date : 14/02/2018
Show Technical Document Details
Question:

There's a warning that occurs 3 times in the output file referring to 'includeantruntime' and 'bootstrap' that I don't get on my 8.0 machine. Do you think it's a concern? 

[javac] C:\models\omssweb.ief\java\LW840001.XML:75: warning: 'includeantruntime' was not set, defaulting to build.sysclasspath=last; set to false for repeatable builds 

[javac] Compiling 11 source files to C:\models\omssweb.ief\java\classes\LW840001 

[javac] warning: [options] bootstrap class path not set in conjunction with -source 1.6 

[javac] 1 warning

Answer:

The first warning ‘includeantruntime’ is something that should have seen in 8.5 also. It is a “misfeature” of ant 1.8 that we use when calling the java compiler. 

 

The second warning comes from our “target=1.6” setting in the XML for the application being compiled. We set this to 1.6 in order to allow backward compatibility. Some app servers are still using 1.6 runtimes and we did this to allow Gen users to still target those app servers. Since are not yet using newer, post 1.6, java features, the users will not experience runtime problems. 

 

Both warning messages can be safely ignored.