Build 152 for 6.0 or 93 for 6.1 is needed but CA CSM not allowing it/GIMAPI ERROR after z/OS 2.3

Document ID : KB000124412
Last Modified Date : 02/05/2019
Show Technical Document Details
Issue:
CA CSM fails while applying  maintenance with GIMAPI ERROR Additional Diagnostic Data: Serious error occurred during initialization of remote GIMAPI extractor. Attached Internal Log: MMI0095S - Loaded GIMAPI program of version 03060096096. Expecting version 03040023 or greater. MMI0084S - Initialization of CAGIMAPI address space failed. This occurs after upgrading to z/OS 2.3 before applying SO05054 or SO05100.
 
The solution is to apply SO05054 for build 152 of 6.0 or  SO05100 for build 93 of 6.1. CA CSM however can not apply these PTF's to itself without failing with the MMI0095S message.
Resolution:
Download attached file libGIMAPI03040026.so and copy it to your /msmroot/msmruntime/tomcat/lib directory.
Verify that the extended attributes are -ps- 
 
Do do this type the folowing in OMVS and hit enter:
cd /msmroot/msmruntime/tomcat/lib
ls -E libGIMAPI03040026.so
It should return:
-rwxrwxrwx  -ps-  1 userid  groupid    libGIMAPI03040026.so 
 
If it does not show the p and s attributes use these commands in OMVS and hit enter:
extattr +p libGIMAPI03040026.so 
extattr +s libGIMAPI03040026.so 
 
Recycle MSMTC then apply and deploy the PTF for your release of CA CSM. 

 
File Attachments:
libGIMAPI03040026.so