Broker goes down on occassion for both Development and Production boxes

Document ID : KB000109084
Last Modified Date : 02/08/2018
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Issue:
Once in a while we have the broker go down on the development box (about every 3-4 weeks) and on the production box (maybe once in 6 weeks). Not sure why. How can we find the reason for this?
Environment:
CA Harvest SCM all platforms and versions
Cause:
In searching through the hserver logs there were several places where the HServer lost connection with the Oracle database:

20180620HServer11503.log (3 hits) 
2018/06/20 13:30:04 Line 10948: -- HServer Disconnected from the Data Source 
2018/06/20 14:21:34 Line 21456: -- HServer Disconnected from the Data Source 
2018/06/20 14:23:07 Line 23748: -- HServer Disconnected from the Data Source 
20180620HServer11693.log (1 hit) 
2018/06/20 14:18:14 Line 19684: -- HServer Disconnected from the Data Source 
20180725HServer11595.log (2 hits) 
2018/07/25 07:56:36 Line 19: -- HServer Disconnected from the Data Source 
2018/07/25 07:56:36 Line 30: -- HServer Disconnected from the Data Source 
20180725HServer11784.log (1 hit) 
2018/07/25 07:56:46 Line 19: -- HServer Disconnected from the Data Source 

The dates and times were the same as when the outages were observed.
Resolution:
Looks like Oracle and/or server is being taken down without our knowledge.

Any time the Oracle database goes down or is restarted, the SCM Broker should be shut down and restarted as well.