Blocked Jobs in Workflow Cannot be Unblocked if successors "Go Immediately"

Document ID : KB000084502
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
Unblock is not possible in workflows.

Problem statement: The 'unblock task' does not really unblock the workflow. 

Investigation
1. Blocked1 (2) failed 
2. Select "Go Immediately" on Blocked2 (3) and let it run the rest of the stream. 
3. Select "Unblock Task" on Blocked1 (2) so that the other successor, Blocked2 (4), can run. The successor runs and completes; however, Blocked1 (2) is still yellow and kicks out a notification alert. 

EXPECTED: Blocked1 (2) changes its color from yellow to red and the "END" process completes. 
ACTUAL: Blocked1 (2) stays yellow and the "END" process never completes. 

 
Cause:
Cause type:
Defect
Root Cause: An error has been fixed where unblock was not possible any more in workflows after "go immediately". The unblocked path within the workflow does resume, but the END task does not get executed and the workflow does not end.
Resolution:
Upgrade to a newer version of the Automation Engine.

Fix Status: Released

Fix Version(s):
Component: Automation Engine

Automation Engine 12.0.0 - Available
Automation Engine 11.2.2 - Available
Automation Engine 10.0.8 - Available
Automation Engine 11.1.4 - Available
Additional Information:
Workaround :
Change 'task properties' of BLOCKED2(3) and BLOCKED2(4) to have dependencies, 'block+abort signal'. 

Result
Select "Go Immediately" on Blocked2 (3) and let it run the rest of the stream. Customer later resolves the issue and is now ready for Blocked2 (4) to run, so go back and select "Unblock Task" on Blocked1 (2) so that the other successor, Blocked2 (4), can run. The successor runs and completes, however Blocked1 (2) is still yellow and kicks out a notification alert, but this time, the "END" process is complete.