bkrd not started after new installation scm v13

Document ID : KB000119975
Last Modified Date : 06/11/2018
Show Technical Document Details
Introduction:
After installing the CA Harvest Software Change Manager v13 on linux redhat7 can not start the broker.

Error message in logs:
HServer | 20181011 11:21:28 | ERROR: E0302004d: Cannot connect to the datasource harvest as user harvest .
HServer | 20181011 11:21:28 | ERROR: [CA Harvest SCM][ODBC 20101 driver]1229 SQLSTATE=60 HServer
Background:
No upgrade option was used, it was a new installation.

Error Message descirption in our documentation: 
-------------- ----------------------------------------------------
E0302004d 
Cannot connect to datasource %s1 as user %s2. 
Reason: 
Cannot connect to the database as either the user name and or the password might be incorrect. 
Action: 
Confirm that the user name and password are correct. 
Verify that the ODBC data source is properly assigned to the correct DBMS instance or service name. 

Researchings: 
-------------- 
- Migration KB attached to the Case 
- Researching documentation for Error 
- Researching Cases / Knowledge Base for Error 
- Sended steps to check odbc and sid 

Logs: 
------ 
HServer | 20181011 11:21:28 | --------------------------------------------- 
HServer | 20181011 11:21:28 | CA Harvest SCM Server 13.0.3 
HServer | 20181011 11:21:28 | --------------------------------------------- 
HServer | 20181011 11:21:28 | Patch level checking is disabled for login transactions... 
HServer | 20181011 11:21:28 | Password exposure checking is disabled for command line utilities... 
HServer | 20181011 11:21:28 | SCM Server Executable Directory: "/opt/CA/scm/bin/" 
HServer | 20181011 11:21:28 | Initialize communication layer... 
HServer | 20181011 11:21:28 | Connecting through datasource harvest using user harvest... 
HServer | 20181011 11:21:28 | ERROR: E0302004d: Cannot connect to the datasource harvest as user harvest . 
HServer | 20181011 11:21:28 | ERROR: [CA Harvest SCM][ODBC 20101 driver]1229 
SQLSTATE=60 

HServer | 20181011 11:21:33 | ERROR: E0302004d: Cannot connect to the datasource harvest as user harvest . 
HServer | 20181011 11:21:33 | ERROR: [CA Harvest SCM][ODBC 20101 driver]1229 
SQLSTATE=60 


Webex and Testings: 
------------------- 
.Execute HBsetup and use CO option 
on the part of testing the connection. this message was missing. 
"Connection test succeeded" 
There seems to be the problem. 
Return code: -1 
0 [CA Harvest SCM][ODBC 20101 driver]1229
Environment:
CA Product = SOFTWARE CHANGE MANAGER 
Product Code = SCMBF199000 
Product Release =12.1 
Red Hat 7 
New installation on this SCM R13.0 
Oracle 11.1 
Instructions:
ROOT CAUSE:
=============
- Customer's tnsnames.ora file is not in $ORACLE_HOME/network/admin. They are using a custom location - TNS_ADMIN variable is not set in their environment.

RESOLUTION:
============
Option#1- Set TNS_ADMIN variable or Option#2 - Copy tnsname.ora file into $ORACLE_HOME/network/admin directory
Additional Information:
Also this documents can help with such problem, worked with the customer through all:
- 000025690 How to reconfigure Harvest server on UNIX/LINUX when $ORACLE_HOME and/or $ORACLE_SID changed?  
- 000055200 When I start my Broker from a command prompt window it starts up correctly. But when I try to run it as a service with a SQL Server database on a Windows platform, startup fails. Why is this                           and how do I correct the problem?
- 000072609 Harvest database migration
- 000101635 working through service name odbc.ini tnsnames.ora service names how to configure