Baseline Engine and Prediction Engine probes won't start

Document ID : KB000046046
Last Modified Date : 14/02/2018
Show Technical Document Details
 
 

Problem: 

I get the following error in the baseline_engine log: 

com.nimsoft.nimbus.NimClientSession(0.0.0.0/0.0.0.0:62526-/81.20.232.17:48000): Connection has been shutdown: javax.net.ssl.SSLHandshakeException: No appropriate protocol (protocol is disabled or cipher suites are inappropriate)

Probes baseline_engine and prediction_engine won’t start, showing a red status.

 

Cause:

When deploying ppm to a hub configured in SSL ONLY mode, baseline_engine and prediction_engine won’t start because of the SSL setting.

 

Environment:

UIM 8.x with a hub configured to communicate in SSL ONLY mode.

PPM

 

Workaround: 

- This problem has been resolved in certain environments by executing the following procedure:

1.       Navigate to nimsoft/jre/<jre.version>/lib/security on the hub where you have SSL ONLY Mode enabled, and where you deployed ppm. It should look something like C:\Program Files (x86)\Nimsoft\jre\jre7\lib\security.

2.       In that directory, open up the java.security file in a text editor.

3.       Under the heading: 
# Algorithm restrictions for Secure Socket Layer/Transport Layer Security # (SSL/TLS) processing
Check if you see an entry that looks like the following: 
jdk.tls.disabledAlgorithms=SSLv3, which does not have a '#' in front of it (thus being uncommented).

If that’s the case, comment the mentioned line (adding a ‘#’ as the first character) and restart the system.

After this change, the line should be read as:

#jdk.tls.disabledAlgorithms=SSLv3

 

Additional Information:

 

-          As always, please contact CA Technologies support for CA UIM if you have further questions.