Banner Agent Jobs fail with "ERM-NOLOGIN: Unable to CONNECT to ORACLE after 3 attempts" error

Document ID : KB000084826
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
Password: ORA-01005: null password given; logon denied
Username: ORA-01017: invalid username/password; logon denied
ERM-NOLOGIN: Unable to CONNECT to ORACLE after 3 attempts

After upgrading Banner General release, all Banner Jobs submitted through Applications Manager fail with the above error. No changes were made the Banner jdbc connection object or the Banner program login object. Furthermore, no changes were made to the authentication method such as implementing Oracle Wallet.

This error can occur for a number of reasons, but it is likely a custom code in the gjajobs.shl script that is causing the error. Depending on whether you are using Applications Manager supplied gjajobs.shl or Banners supplied gjajobs.shl, review the active custom gjajobs.shl with a "clean" version of the gjajobs.shl to compare and review all custom code changes. Below is an example code where Applications Manager custom code is overwritten by another custom code changing the behavior of how passwords are handled when Banner Jobs are submitted through Applications Manager.

# Begin UC4 Modification so password is not displayed in process list
case $PSWD in
/) UIPW=$PSWD;;
*) UIPW=$arg3/$PSWD;;
   <-- AM custom code
esac
# End UC4
#
# Check if the password is set to "/" (meaning $OPS login).
#
case $arg4 in
/) UIPW=$arg4;;

*) UIPW=$arg3/$arg4;;   <-- Additional custom code which overwrites AM custom code
Esac

 
Environment:
OS Version: N/A
Cause:
Cause type:
Configuration
Root Cause: Custom gjajobs.shl code error
Resolution:
Review and fix all custom gjajobs.shl code issues.

Fix Status: No Fix

Fix Version(s):
N/A
Additional Information:
Workaround :
N/A