Backward compatibility of the CORBA interface.

Document ID : KB000103231
Last Modified Date : 25/06/2018
Show Technical Document Details
Introduction:
Our client has written an interface between Optic (IBM) and CA Spectrum that reads some alerts out of Spectrum.
It was developed for a previous version of Spetrum; 9.x and later ported to 10.2.2, where it currently works with no problems.  
The customer will soon upgrade to a newer version of Spectrum and has concerns that the interface will continue to work. 
Question:
Are there any changes to the CORBA interface or alarm structure on Spectrum 10.2.3 and 10.3, when compared to Spectrum version 10.2.2?
Environment:
Spectrum 10.x and IBM Optic.
Answer:
There are no changes to the CORBA, so they can upgrade it without any impact.
Additional Information:
Our docs show no updates to Corba in that time period.
https://docops.ca.com/ca-spectrum/10-2-3/en/release-information/features-and-enhancements 
https://docops.ca.com/ca-spectrum/10-1-to-10-1-2/en/release-information/features-and-enhancements/

Plus our docs show no updates to Corba in the upcoming 10.3. release.
https://docops.ca.com/display/CASP1030/Features+and+Enhancements

The following links may also be of interest to you. 

https://docops.ca.com/ca-spectrum/10-2-3/en/programming/development-api-reference/version-requirements 
https://docops.ca.com/ca-spectrum/10-2-3/en/programming/spectrum-integrator/extending-ca-spectrum-with-the-corba-api