AXA 17.3 fails to install on RHEL 7 update 4

Document ID : KB000071357
Last Modified Date : 19/02/2018
Show Technical Document Details
Issue:
When running the AXA /aoPlatform 17.3 installer on Red Hat Linux 7 update 4, the installation will not complete and fail with this error:

Configuring the installer for this system's environment...
XMLScriptReader: unable to parse the provided script file. File may have been invalid...
java.lang.NullPointerException
at Flexeraan8.am(Unknown Source)
at Flexeraan8.ak(Unknown Source)
at Flexeraan8$1.aa(Unknown Source)
at Flexeraair.ad(Unknown Source)
at Flexeraan8.ac(Unknown Source)
at com.zerog.ia.installer.LifeCycleManager.b1(Unknown Source)
at com.zerog.ia.installer.LifeCycleManager.a8(Unknown Source)
at com.zerog.ia.installer.LifeCycleManager.au(Unknown Source)
at com.zerog.ia.installer.LifeCycleManager.consoleInstallMain(Unknown Source)
at com.zerog.ia.installer.LifeCycleManager.executeApplication(Unknown Source)
at com.zerog.ia.installer.Main.main(Unknown Source)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at com.zerog.lax.LAX.launch(Unknown Source)
at com.zerog.lax.LAX.main(Unknown Source)

 
Environment:
RHEL 7.4
This is detected by the installation routine:
[validations.sh] [INFO]: Required minimum RHEL OS version: 7.1, available: 7.4
Resolution:
The only option is to use the supported version of RHEL, which is currently 7 update 2,

Please review below note, this is mentioned in Jarvis documentation as related to DISPLAY variable.
However when using RHEL 7.4, the install will still fail even after implementing this.
Additional Information:
AXA OS support information

https://docops.ca.com/ca-app-experience-analytics/en/supportability-matrix#SupportabilityMatrix-OperatingSystem

Note on Jarvis documentation,

https://docops.ca.com/ca-jarvis/2-0-4/en/troubleshooting/#Troubleshooting-IamgettingXMLScriptReadererrorwhileinstallingCAJarvis.