AWA promptset error: Invalid value in property

Document ID : KB000115797
Last Modified Date : 13/12/2018
Show Technical Document Details
Issue:
Executing the object with the PromptSet gives the following error if &$PHYS_DATE_MM_DD_YYYY_s# VARA is referenced in the PromptSet: 
“Invalid value '01/01/2018' in property 'Default Value' of the promptset date field 'Time/Date' (expected format: 'yyyy-MM-dd'). The field will be reset to the current system datetime.”  
User-added image
The issue is only present in Automic Web Interface (AWI). 

Investigation:
1.    Create a SCRI object (can be any job)
2.    Create a PromptSet and add it to the job: 
a.    Add Time/Date element
b.    In the General Setting, select Type as “Date”
c.    DataReference as UC_DATATYPE_DATE
d.    Put in the variable name as &DATETIME2# (as an example, can be any name) 
e.    The default value should be set up as “Set by Variable”
f.    The Toolip is &$PHYS_DATE_MM_DD_YYYY_s# 
g.    The value of the promptest is set by &$PHYS_DATE_MM_DD_YYYY_s#
3.    In the SCRI object in the process tab put in :PRINT &DATETIME2# command, and execute the SCRI object
4.    When the SCRI object is executed, the following error pops-up: 
“Invalid value '09/11/2018' in property 'Default Value' of the promptset date field 'Time/Date' (expected format: 'yyyy-MM-dd'). The field will be reset to the current system datetime.”
5. Once the pop-up message is closed, fulfill the request, and then it prints the correct date
Cause:
This is a bug.
 
Resolution:
Please update to a fixed version:

Automation Engine 12.0.7 - planned release on 2019-01-14 
Automation Engine 12.3.0 - planned release on 2019-04-23
Automation Engine 12.2.2 - planned release on 2019-02-28
Automation Engine 12.1.5 - planned release on 2019-05-20