[AWA] newly installed Informatica Agent terminated immediately after start

Document ID : KB000115308
Last Modified Date : 19/09/2018
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Issue:
After installed a new RA Informatica Agent, it is not possible to start the agent, even the config, license & installation steps were correct.
  • RA Agent log:
U02013317 The RA Solution returned error code '0'.
U00003620 Routine 'UCEX_R' forces trace because of error.
...
U02000041 Shutdown Agent 'RA_INFORMATICA'.
           Agent Stopped
U02000010 Connection to Server 'x.x.x.x.:2217' terminated.
U02000002 Agent 'RA_INFORMATICA' version 'x.x' ended abnormally.
  • RA Agent trace:
java.lang.RuntimeException: Agent Definition data for pmcmd path is null. Edit the host table agent definition and save, then restart Agent.

 
Cause:
A mandatory setting for Informatica agent has not been set on the Automation Engine
Resolution:
  • Go to client 0, right click on the Informatica agent, and go to Informatica tab, then you can specify the path to"pmrep and pmcmd" directory.
  • Restart/Start RA Agent
Additional Information:
Configuring the RA Informatica Agent Solution Agent