[AWA] Job messenger path error

Document ID : KB000103219
Last Modified Date : 25/06/2018
Show Technical Document Details
Issue:
There are 2 Windows Agents, but Jobs only run successful on one node, on the second node, it displays wrong Job messenger path in job report:

Program 'UC4 Job Messenger' version '12.1.0+build.796' started
UCMDJP: *********************************************************************
UCMDJP: ** JOB 0001250008 (ProcID:0000006180) START AT 31.05.2018/08:40:13 **
UCMDJP: ** UTC TIME 31.05.2018/00:40:13 **
UCMDJP: *********************************************************************
Connected with agent 'IORPER-ATA02' Program 'UC4 Job Messenger' version '12.1.0+build.796' terminated normally
************************************************************************************
SPO Sitename: WAIOSPOAuto
Job Name: JOBS.WIN.PS.SPO_QUOTA.CHANGE

Exception found: System.Management.Automation.CommandNotFoundException
Exception text: The term 'D:\Automic\Agents\windows\bin\ucxjwx6m.exe' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.


The above path was correct for node 1 while the correct path on second node should be: D:\Automic\Agents\Windows02\bin
Setting in the ini config file shows: UC_EX_JOB_MD=.\UCXJWX6M.EXE
Environment:
Windows Agent
Cause:
Background:
  • Job messenger's path is defined in the ini config file with parameter: UC_EX_JOB_MD which could be used as reference variable in script.
  • UC_EX_JOB_MD=.\UCXJWX6M.EXE means that the Job messenger is set to the ucxjwx6m.exe file in the same folder as the config file (i.e bin folder of the agent).
  • The configuration found above is correct. First half of the job report shows that Job messenger works normally.
Investigation:
  • If Job messenger path is wrong then there should be no such report
  • It looks like at some point of the Job, there's a function calling for Job messenger at the wrong path.
Resolution:
Conclusion:
  • After revising the Job design: a path value was found hardcoded into the job causing the issue. Change the value to a variable or modify the agent's path to a corresponding path would solve the issue.