AutoSys upgrade fails: scripts/as_navigation.sh[25]: perl: not found.

Document ID : KB000013438
Last Modified Date : 14/02/2018
Show Technical Document Details
Question:

During the upgrade of autosys to r11.3.x the product fails with the following:   

scripts/as_navigation.sh[25]: perl: not found. 

 

Environment:
Workload Automation AE 11.3.xPlatform - UNIX/LINUXDatabase - ANY
Answer:

The environment did not have perl in the PATH or LIBPATH. 

The client ran the following:

PATH=/usr/opt/perl15/bin:$PATH 

LIBPATH=/usr/opt/perl15/lib:$LIBPATH 

export PATH

export LIBPATH

Then wa_setup.sh ran without problems.