Autoping Fails from Shadow Application Server Machine

Document ID : KB000005356
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

A new instance of WAAE is installed and is configured for HA. When issuing an autoping command from the primary Scheduler machine, it works fine. However, when issuing an autoping command to any agent from the shadow Scheduler machine, it will fail with the following error...

CAUAJM_I_50023 AutoPinging Machine [machine1]
CAUAJM_I_50280 AutoPing from the Scheduler WAS SUCCESSFUL.

CAUAJM_E_10229 Communication attempt with the CA WAAE Agent has failed! [machine1:7520]
CAUAJM_E_50283 AutoPing from the Application Server WAS NOT SUCCESSFUL.

CAUAJM_E_50026 ERROR: AutoPing WAS NOT SUCCESSFUL.

The error indicates that the autoping from the Scheduler works fine but fails from the Application Server.

If the receiver.log file is viewed on an agent where the autoping failed, the following error can be seen...

01/06/2017 11:43:09.746 CST-0600 1 TCP/IP Controller Plugin.Receiver pool thread <Regular:2>.CybReceiverChannel.receive[:213] - Can't parse the message: cybermation.library.communications.CybConversationWrongMessageException: Undecipherable message .NAK sent

 

Cause:

The autoping will look at the local configuration file on the machine from which the autoping is issued. From that file it gets the value for AutoServerId and sends that to the agent. This is how the agent knows where to send a response.

During the installation of WAAE, the AutoServerId is automatically set to <INS>_APP_<local host name> where <INS> is the three-character instance name. The <local host name> is taken from what is specified for the Application Server host name during the install interview. This question during the install interview allows for multiple Application Server machines to be entered separated by a comma. When multiple servers are entered, the installation ends up using both when building the AutoServerId. However, the AutoServerId should only have the local host name. When it has multiple hostnames with the comma, it causes a parse issue on the agent side as seen in the error from the receiver.log. The message that cannot be parsed is the one from the Application Server. Therefore, the result of the autoping is that it succeeds from the Scheduler but not from the Application Server.

Resolution:

Modify the AutoServerId so that it only contains the local hostname. For example, if the current value looks like this...

AutoServerId=ACE_APP_LOCALHOSTNAME,HOST2

Change it to...

AutoServerId=ACE_APP_LOCALHOSTNAME

Once the change is made, recycle the Application Server and retry the autoping command.