Automation Process failed to complete with an error message "Could not connect to database; -url=Process.CommonDS.SCDBConnectionString_MDB - No suitable driver found for Process.CommonDS.SCDBConnectionString_MDB"

Document ID : KB000008916
Last Modified Date : 14/02/2018
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Issue:

Troubleshooting failed process instance using the global data-set connections

Environment:
CA Service catalog 14.1CA Process Automation 4.2CA Service Desk Manager 14.1
Cause:

Connection string URL is not captured even after saving the new URLĀ information in the process design

Resolution:

Validate that the process is capturing the right information from the connection string URL by following the below steps

1. Login to Process Automation (CA ITPAM) with admin rights

2. open the troubled process and checkout to edit

3. Copy the ConnectionString value for future use

4. Clear the contents in the ConnecitonString and Save the process by Checkin button to save the updates

Note: Run the process manually to confirm that that ConnectionString values are blank in the process instance. The process instance should fail complaining that the URL is empty.

5. Checkout the process again and update the ConnecitonString value with the contents that were removed from Step 3

6. Click on checkin button to save the process with the new updates

7. Run the process manually to check if the process is completed in this case with a successful Database connection.

Additional Information:

Note: The above simple example is specific to a database connection issue using PAM process