Automation Engine and Informatica latency

Document ID : KB000087938
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
N/A

Informatica jobs finish within Informatica, but from the Automation Engine (AE) they are still in a "Running" status and there is a significant delay before they show as finished in AE.

Example:

JOBS.INFA.EDW_APPLICATION.WF_APP_LOAN_SK_FROM_OCEAN:
  • Time to run and finish in Informatica: 24 seconds
  • Time to run and finish in Automic's AE: 21 minutes

0EMb0000001Ug1I.png
Environment:
OS Version: N/A
Cause:
Cause type:
Configuration
Root Cause: Select the 'Disable Synchronized WorkFlow Job Launching’ option to avoid latency.
Resolution:
The option " Disable Synchronized WorkFlow Job Launching " must be checked.

In fact, there are several configurable options on the Agent and one of them is the ‘Disable Synchronized WorkFlow Job Launching’ option. We would recommend this option only in a very specific cases where you need to handle large number of Informatica Workflows which are launched simultaneously.

Caution:  Depending on the Informatica system configuration and the number of jobs submitted in parallel from Automic, checking this option can also cause a performance issue, Workflow logs not to be retrieved, and a potential Informatica resource contention with jobs waiting to start.


0EMb0000001Uhl7.png


 

Fix Status: No Fix

Fix Version(s):
N/A
Additional Information:
Workaround :
N/A