Automation Builder License for Agile Designer

Document ID : KB000004995
Last Modified Date : 14/02/2018
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Issue:

How do I receive an Automation Builder license for Agile Designer?

 

When using Agile Designer's Automation feature, I am receiving the following message:

Starting from version 2.4.000.X, Automation will be enabled only for the following licenses: Automation Builder. The license you are currently using does not support Automation. If you wish to continue using the feature after updating to version 2.4.000.X, please contact CA Support or your CA Account Manager. 

 

automation builder license message.PNG

Environment:
CA Agile Requirements Designer (ARD)- Agile Designer 2.3 and 2.4+
Cause:

When you upgrade to ARD 2.4, you will need to request and apply a new 'Automation Builder' license in order to use the Automation feature.

 

If you are using ARD 2.3, this is just an informational message letting you know about the licensing change and you will be able to continue using the Automation feature as normal.

Resolution:

If you apply an Automation Builder license to ARD 2.3 or 2.4+, you will be able to use the Automation feature without receiving a pop-up message. Below are directions on how to request and apply an Automation Builder license.

 

Create a license request case:

  1. Go to and login to CA Support Online: https://support.ca.com/irj/portal/newhome 
  2. In the top, left-hand corner of the screen, click the 'Menu' bar, which is an icon with three horizontal lines.

  3. Click on the 'Licensing' option.

  4. On the CA Licensing page, scroll to the very bottom and click on the 'Customer Care Request Form' link. 
    • Here you will be taken to the 'Customer Care Request Form': https://catech.force.com/customer/CustomerCareForm

  5. Fill out the following 'Account Information':
    • Please indicate your relationship with CA: (CA Customer, CA Employee, Other)
    • CA SiteID: If you do not know this, please call 1-800-225-5224 or contact CA Support at http://www.ca.com/us/services-support/ca-support/contact-support.html 
    • Request Type: CA Licensing
    • First Name:
    • Last Name:
    • Company Name:
    • Company Address:
    • Country:
    • City:
    • State/Province:
    • Postal/Zip Code:
    • Telephone Number:
    • Corporate Email Address:

  6. Fill out the following 'Details' information:
    • Type of License: General Licensing for All Other Products
    • Your Question: Require CA Agile Requirements Designer license with Automation capabilities. (Automation Builder Add-On)
    • Product Name: CA Agile Requirements Designer (Agile Designer)
    • Release: 2.6 (or whichever version you are currently using)
    • Type of Licensing: All Other Keys
    • Do you have any files to attach to this case?: Yes if you need to attach a license request file for offline licenses (WibuCmRaC file). No if you only need an online license key.
    • Please check and follow the instructions below: Check box for 'I'm not a robot'. 

  7. Click the 'Submit' button.

  8. You will get a message saying "Thank you for your submission. You will receive an email with case number 'xxxxxxxx'. The CA Customer Care team will be in touch shortly." Take note of this case number.

  9. Click the 'Close' button once done. A member of our customer care (licensing) team will create the offline license key you require and email you within 24 hours. 

  10. Once you have the license key, follow the next set of instructions.

 

Delete existing/old license:

Follow the steps in this document in order to delete your existing Agile Designer license before applying the new one.

Import license container:

Follow the steps in this document in order to re-import the AgileDesigner license container into CodeMeter Control Center.

Apply the license:

Follow the application steps in either of the below documents. (Skip to the 'Apply the license' section)

Additional Information:

If you experience any issues, please open a support case by going to https://support.ca.com or calling one of these numbers https://www.ca.com/us/services-support/ca-support/contact-support.html

 

The below documentation gives more details on the Automation Feature and how to use it: