Attempting to filter alarms and alarm filter is not recognizing a hub

Document ID : KB000107733
Last Modified Date : 24/07/2018
Show Technical Document Details
Issue:
Two hubs were not listed in the Infrastructure Manager (IM) alarm subconsole window, hence not available for filtering alarms from those hubs.
Environment:
- UIM 8.5.1
- hub 7.8x/7.9x
Cause:
- Both hub robots were in a hung state
- example controller.log from one of the hung robots

Jun  8 22:54:21:865 [140596953806592] Controller: ProcessControl: Sending SIGTERM signal to logmon (43114)...
Jun  8 22:54:21:865 [140596953806592] Controller: ProcessControl: Unable to send stop signal to process logmon (43114)
Jun  8 22:54:22:865 [140596953806592] Controller: ProcessControl: Child exited
Jun  8 22:54:22:865 [140596953806592] Controller: ProcessControl: Sending SIGTERM signal to net_connect (46043)...
Jun  8 22:54:22:865 [140596953806592] Controller: ProcessControl: Unable to send stop signal to process net_connect (46043)
Jun  8 22:54:23:865 [140596953806592] Controller: ProcessControl: Child exited
Jun  8 22:54:23:865 [140596953806592] Controller: ProcessControl: Sending SIGTERM signal to interface_traffic (46171)...
Jun  8 22:54:23:866 [140596953806592] Controller: ProcessControl: Unable to send stop signal to process interface_traffic (46171)
Jun  8 22:54:24:866 [140596953806592] Controller: ProcessControl: Child exited
Jun  8 22:54:24:866 [140596953806592] Controller: ProcessControl: Sending SIGTERM signal to cisco_monitor (118170)...
Jun  8 22:54:24:866 [140596953806592] Controller: ProcessControl: Unable to send stop signal to process cisco_monitor (118170)
Jun  8 22:54:25:866 [140596953806592] Controller: ProcessControl: Child exited
Jun  8 22:54:25:874 [140596953806592] Controller: Controller on xxxxxxxx port 48000 started
Jun  8 22:54:27:012 [140596953806592] Controller: Hub localhost(172.xx.x.xx) contact established
Jul 13 13:28:28:083 [140596953806592] Controller: post-install '/bin/java -jar probes/network/snmpcollector/packageCleaner-1.0.jar probes/network/snmpcollector/pre_install.xml' returned 32512
Resolution:
Two hub machines were not listed in the alarm subconsole filter window in IM, because no alarms were making it through, because the robots entered a hung state at some point in the past. Therefore, they could not contact and send the alarms up to the Proxy hub(s) then on to the primary.

Examine the controller to see if the controller log is being updated. In this case, there were no log updates in a very long time for both systems.

Once the robot was restarted and we generated some alarms from probes on the hub in question, we saw the alarms were received and after a minute or so the hub name(s) now displayed successfully in the alarm subconsole filter window in IM.