Attempting to Close an alert in WCC Alert Widget results in application freeze

Document ID : KB000108970
Last Modified Date : 08/08/2018
Show Technical Document Details
Issue:
From your view in WCC, select Jobs and Alerts, and go down to the Alerts section.
You should see some of your jobs listed there in various states of alarms.  
Right click an alarm and select CLOSE.
When we do that CLOSE the window freezes up and clocks and clocks.
Must exit WCC and log in again.
Environment:
WCC 11.4 SP6 on Windows and Linux
Cause:
Following problems have been fixed by this patch:
 
PROBLEM SYMPTOM: ALL-UWCC-U INCREMENTAL FIX 13-JUN-18              
                 ----------------------------------------------------
                 (A) ECLI & DASHBOARD ALERT FIXES
                 
                 This patch includes fix for following issues in
                 wcc:
                 
                 
                 1. WCC ECLI flips * in autosys_secure command to %
                 
                 In WCC ECLI, Users can change their password using
                 autosys_secure command (if they know the existing 
                 Password). However, because WCC interchanges *
                 with
                 %. So, Users were not able to use * as part of
                 their passwords as WCC was interchanging * in
                 their
                 passwords with %
                 
                 Problem Record: 417
                 
                 
                 2. Not able to close alerts in dashboard alerts
                 widget
                 
                 When alerts are generated and alerts appear in 
                 dashboard Alerts widget, user was not able to 
                 close alerts on right click and CLOSE.
                 
                 Also it impacted other opened alerts like after
                 doing above mentioned operation the options for
                 closing or acknowledging the alerts grayed out.
                 
                 Problem Record: 418
                 
                 
                 (B) WCC QUICK EDIT, MONITORING & REPORTING      
                 FIXES
                 
                 This patch includes fix for following issues in
                 wcc:
                 
                 			  
                 1. WCC "Status Summary" alert box color never
                 changes    
                   
                 In WCC Monitoring, "Status Summary" alert box
                 stays
                 green and says "No New Alerts" even when there 
                 are new alerts. In Status Summary of a Monitoring
                 view, the number of Alert Status does not show 
                 the alerts. It's shown as 1 even if there are
                 more 
                 than one alerts associated with the view.
                 			  
                 Problem Record: 425
                 
                 
                 2. Monitoring View/Server tree refresh not working
                 			 
                 Refresh not working in monitoring view/Server tree
                 section. Status of jobs and time of refresh not
                 getting updated on refrsh when the view/server is
                 in expanded state.
                 			 
                 Problem Record: 426
                 			 
                 
                 3. WCC Reporting cleanup fails
                 
                 Old data in reporting database was not getting
                 cleaned up. Hence WCC Reporting tab shows old 
                 data.
                 			 
                 Problem Record: 419
                 
                 
                 4. Updating a jobs date/time condition fields
                 give error	
                 			   
                 When a job is updated to have 'Minutes after each
                 hour' 
                 from 'Times of day' or vice-versa gives error.
                 			 
                 Problem Record: 429
                 
                 
                 5. WCC unable to open certain jobs in Quick Edit 
                 			
                 Openning jobs in Quick Edit which has many
                 conditions and resources does not load properly
                 or gives
                 blank screen. 
                 			 
                 Problem Record: 428
                 
                 
                 6. Dependency condition does not match with
                 autosys
                 
                 If a job is dependent on another job that is
                 currently in NOEXEC status, then dependent job's 
                 "Condition Satisfied" field under "Starting
                 Conditions"
                 shows wrong condition.
                 
                 Problem Record: 430
                 
                 
                 7. WCC Import Function not working properly
                 
                 In WCC ECLI, if user clicks import button 
                 multiple times  while importing a jil file 
                 give a blank output.
                 
                 Problem Record: 431
                 
                 
                 8.Monitoring and QV shows ECMAScript6 error in IE
                 
                 In WCC Monitoring and QV, while opening a job
                 using Internet Explorer 11 it throws below
                 message:
                 
                 "These demos use ECMAScript 6 features that your
                 browser does not support. Please switch to a
                 browser with support for ECMAScript 6 (Chrome,
                 Firefox,
                 Edge, Safari 10) or use the included deployment
                 tool to convert the demos to ECMAScript 5. The
                 converted demos are also available online. 
                 Note that ECMAScript 6 is a requirement of the
                 demos, only. The  yFiles for HTML library itself
                 is compatible with ECMAScript 5"
                 
                 Note: For the fix to work as intended, follow the 
                 below steps:
                 --Clear the IE browser cache  history and 
                 then close all opened IE browser instances
                 --Restart the IE browser
                 
                 Problem Record: 432
Resolution:
Call CA support to get patch T6FU003