Attaching file to a Request in Unified Self Service (USS) fails without errors. Posting a comment does not work as well.

Document ID : KB000004412
Last Modified Date : 14/02/2018
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Issue:

When creating a Request via Unified Self Service (USS), posting a comment does not work, as well as attaching a file to the comment to be posted:

Request1.jpg

Request2.jpg

 

Observe that no error is produced on the front-end.

Checking the logs does not show any evidence of the problem either, even when enabling traces on both USS and Catalog.

Creating the same Request directly from the Catalog interface works without problems.

Environment:
ITSM 14.1: Unified Self Service integrated with CA Service Catalog and CA Service Desk Manager
Cause:

The problem was caused by the Image field not having a content.

Resolution:

To resolve the problem:


1. Create an image file in Paint, for example, named blank.png. Save it to INSTALL_DIR\filestore\images

Image1.jpg


2. Edit the Form, click the image field and add the following to the URL attribute: Filestore/image/blank.png

Form1.jpg

3. Save and test with USS. It should work now.

Test1.jpg

Test2.jpg