ASM Agent is not able to transmit metrics of the monitors into APM

Document ID : KB000105783
Last Modified Date : 10/07/2018
Show Technical Document Details
Question:
I keep receiving this error each time the Agent makes a request to the https://api.cloudmonitor.ca.com/1.6 or https://api.asm.ca.com/1.6 urls 
 [WARN] [pool-1-thread-1] [CloudMonitorIntegration.CloudMonitorAgent] Problem while getting global Cloud Monitor data (lists of monitors and checkpoints): com.wily.apm.cloudmonitor.cmconnector.rest.RestConnectionProblem: Problem while connecting to Cloud Monitor: https://api.asm.ca.com/1.6/acct_token?user=<user name>&password=[**redacted**] 
Environment:
ASM Agent 9.5
Answer:
In this situation, the 9.5 ASM Agent was being used, which is End of Service.  So an upgrade is required.

The ASM API site has undergone a lot of internal changes since the 9.5 Agent was released, thus causing it to be incompatible with the ASM API. Since 9.5 has been End of Service for a few years now, no code change will be allowed to be done to make it work. 

ASM Agent version 9.7 is compatible with the https://api.cloudmonitor.ca.com/1.6 URL but not with the https://api.asm.ca.com/1.6 URL
Recommendation: Upgrade the ASM Agent to a minimum of 9.7 and use the https://api.cloudmonitor.ca.com/1.6 URL (newer 10.x ASM Agents can use the https://api.asm.ca.com/1.6 URL).  Best move would be to upgrade to the 10.7 version of the Agent.

 
Additional Information: