AS400 Agents refuse to start after update to version 12

Document ID : KB000084735
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
U00011605 The combination of hardware 'xx/xx/xxx' and software 'xxx' version 'xx' ('000000016') is not supported

AS400 agents that ran just fine in a previous version of the Automation Engine refuse to start.   The above error message appears in the agent's logs.

Investigation

The same host has 2 AS400 agents installed. One runs on version 10, and the other runs on v12.

Results

Expected: Because both agents run on the same host, the agent's characteristics should not differ:  OS400 hardware and software version should be recognized similarly in version 10 and version 12 of the Automation Engine.

Actual : The hardware is recognized differently in the agent's logs.

Agent log - Version 10

 
20180314/080400.685 - U2000066 Host information: Host name='My_AS400_Agent', IP address='xxx.xxx.xxx.xxx'
20180314/080401.165 - U2000020 Environment: Hardware = 'MMD/EPM1/30'.
20180314/080401.166 - U2000021 Environment: Software = 'OS/400'.
20180314/080401.167 - U2000022 Environment: SW version = 'V7R3M0'.

Agent log - Version 12
 
20180314/082013.696 - U02000066 Host information: Host name='My_AS400_Agent', IP address='xxx.xxx.xxx.xxx'
20180314/082013.868 - U02000020 Environment: Hardware = 'MMD/EPM1/2'.
20180314/082013.868 - U02000021 Environment: Software = 'OS/400'.
20180314/082013.868 - U02000022 Environment: SW version = 'V7R3M0'
Environment:
OS: IBM AS/400
Cause:
Cause type:
By design
Root Cause: V12 Agent now report the Virtual CPU's and not the physical CPU's like on other platforms.
Resolution:
Contact CA | Automic's support so they can provide a patch for the UC_HTYP table.

After updating the UC_HTYP table as instructed, the agent will be able to start.


Fix Status: No Fix

Additional Information:
Workaround :
N/A