Are the CA Datacom version 15.0 PC modules downward compatible to version 14.0?

Document ID : KB000012157
Last Modified Date : 14/02/2018
Show Technical Document Details
Question:

I am planning to upgrade my CA Datacom/DB software from version 14.0 to 15.0. Since we only use one loadlib at the IPL time for all products, we can't have two versions of the PC modules in the same loadlib. Can I use the version 15.0 modules with my v14 systems?

Answer:

Each version of the PC modules is specific to that release. Therefore they cannot be shared in a common CAS9/CAIRIM loadlib.

A possible alternate process is to load the version 14.0 modules as normal through CAIRIM, and then have an automated or scheduled routine submit the BDRIM01 job for version 15.0 to load those modules from the version 15.0 loadlib. Then, once every system has been upgraded to version 15.0, you can change the CAIRIM process to load the version 15.0 PC module, and disable the automated routine.

Additional Information:

As always, please contact CA Technologies support for CA Datacom if you have further questions.

***