ARA/CDA Upgrade package CustomType version on existing packages fails

Document ID : KB000126470
Last Modified Date : 11/02/2019
Show Technical Document Details
Issue:
Created a new package type with version 1.6 and activate it Now when we try to upgrade two entities from old version 1.5. to newly created version 1.6 it is throwing an error.
User-added image
Environment:
Release.Manager 9.0.0, Release.Manager 8.0.3
Cause:
Upgrade package to a new package type which introduce new milestones *and* reorder existing milestones will cause this error. Fix by force update positions of existing milestones before inserting new one.
Resolution:

The issue was found and fixed with Release.Manager 8.0.4 in Release Manager. The Package is available for download at the Automic-Support-Zone (https://support.automic.com).

Hotfix-Description: Error when upgrading a package to a new package type version which creates new milestones between existing milestones.

An issue has been fixed where, when upgrading a package to a new package type version which creates new milestones between existing milestones, an error occurred.

The issue also got fixed in the following version
Release.Manager 10.0.0,Release.Manager 9.0.2