Applications Manager 9.3 compatibility with Java and OpenJDK

Document ID : KB000125010
Last Modified Date : 21/01/2019
Show Technical Document Details
Question:
What are the plans for Java and OpenJDK compatibility with Applications Manager moving forward?

What available details are available and what does this mean for Applications Manager 9.2.2 and below?
 
Answer:
The planned Java Roadmap for Applications Manager is to be compatible with both Oracle Java 11 and OpenJDK 11 on Applications Manager version 9.3.

The client jar file will include a connections.properties file that can be edited which adds the ability to connect to multiple Applications Manager instances.


Applications Manager version 9.2.2 or below will NOT receive an update for Java 11/OpenJDK 11 compatibility. Users running Applications Manager version 9.2.2 or below will be required to continue using Java 8 and Java Webstart.