APM is unable to instrument WAS Liberty when set at the common configuration level.

Document ID : KB000008262
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

 After setting up the APM Java Agent with Websphere Liberty at the common configuration level (<Liberty_Home>/etc/jvm.options), the agent fails to load with errors such as:

Error opening zip file or JAR manifest missing : "/Agent/wily/Agent.jar" 

JVMJ9TI064E Agent initialization function Agent_OnLoad failed for library instrument, return code -1 

JVMJ9VM015W Initialization error for library j9jvmti28(-3): JVMJ9VM009E J9VMDllMain failed 

Environment:
APM 10.x Java Agent WAS Liberty 17.x
Resolution:

 Rather than configuring Liberty to use the agent at the common configuration level, this should be done at the server level (<Liberty_Home>/usr/servers/<Liberty_Server_Name>/jvm.options).