APM Connector is throwing a token error.

Document ID : KB000005009
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

After deploying and integrating APM Connector with Introscope, I am not able to login into APM Team Center using a token.

The following error is being logged multiple times:

ERROR [MdrMonitorThread] wily.apm - Unable to connect using token : HTTP/1.1 401 Unauthorized.
WARN [MdrMonitorThread] connector.ApmConnector - Team Center unavailable but EM is running - proceeding but unable to process application map

 

Environment:
Introscope 10x APM Connector 3.1.0
Cause:

 The original token was not entered correctly in the SOI configuration file:

 APM_caapmvmwlnxv14.gp.inet.xml

 

Resolution:

1- Go to APM Team Center > References > Security and click on "Generate New Token".

ATC.png

2- Copy the new token and put it in the \soi\resources\configuration\APM_caapmvmwlnxv14.gp.inet.xml.

3- Restart the APM Connector.

 

Additional Information: