APM ACC upgrade using upgradetool.sh/bat fails with an error message.

Document ID : KB000007908
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

  An APM Command Center Server (ACC) upgrade with upgradetool.sh/bat fails with this error message. (The version information may vary according to your environment.):

[ERROR] Upgrade failed: Version of the tool from the package provided is lower than the current one (10.5.2.11 < 10.5.2.8). Downgrades are not supported.

Environment:
APM 10.5.2.
Cause:

 Version comparison is implemented as lexicographical instead of numerical comparison. Therefore “10.5.2.11 < 10.5.2.8” is assumed and the installation aborts.

 

Resolution:

  Override the version to upgrade from by using -Dcom.ca.apm.acc.upgrade.version=10.0.0.0.

This helps by overriding the old version string used for checking.

The steps to do this are below:

1. Open upgradetool.sh/bat with an editor

2. Add a line “-Dcom.ca.apm.acc.upgrade.version=10.0.0.0 \” to the $JAVA_CMD string at the end of the file.

3. Save the file.

 

4. Verify that the whole command should now read:

"$JAVA_CMD" \

-DLOG_LEVEL=$LOG_LEVEL \

-DTAR_PATH="`which tar`" \

-DINSTALL_DIR="$INSTALL_DIR" \

-DVALIDATE_RUNS_CORRECTLY \

-Dcom.ca.apm.acc.upgrade.version=10.0.0.0 \

-jar /tmp/acc-upgradetool.jar $*

Additional Information:

This issue will be fixed in a future version or service pack of CA APM.