APM 12.9 common asset viewer AMS fails to install

Document ID : KB000029442
Last Modified Date : 14/02/2018
Show Technical Document Details

During the APM 12.9 installation, the common asset viewer component may fail to install.

Common asset viewer (AMS) requires the installation of a 32-bit JDK (1.7_40 or higher, but not 1.8)

  • If a prior install was attempted, navigate to services and check that the Apache Tomcat AMS service is stopped.
  • Install a 32-bit JDK. as above
  • Add a JAVA_HOME environment variable  (for example: C:\Program Files (x86)\Java\jdk1.7.0_45
  • Add  %JAVA_HOME%\bin to the system environment path variable 
    NOTE:  the JRE path is not needed for APM 12.9 
  • Click retry on the APM installation screen to retry the failed component