APM 10.7 Team Center Metric Browser no data in Live mode

Document ID : KB000102932
Last Modified Date : 21/06/2018
Show Technical Document Details
Issue:
When using the Metric Browser in Team Center in APM 10.7, you might find there is no live data.
Message "There is no data for the selected time range"

If you change to historical mode to show the last eight minutes, data will be shown.

If you compare to live mode in either WebView or Workstation, the live data will be there.
Environment:
APM 10.7
Cause:
The problem here was that the system time on the Enteprise Manager system was incorrect, in this case the system time was actually in the future.

Compare the URLs in Team Center for the historical last 8 minutes request against the live request.
The last section of the URLs is key.

Historical


http://apmhost:9180/ApmServer/#/metrics?fa=%5B%5D&ep=0&m=H&l=ATC&u=UNFWEnterprise%20Team%20Center&cht=0&chs=1&cha=0&selectedMetrics=%5B%22SuperDomain%7CAPMHost%7CCommon%7CAgent%7CMonitored%20Servers%7CApache%20Web%20Servers%7CApache%7CAPMHost%7CAvailability:Availability%20Status%22%5D&ts1=1529512260000&ts2=1529512740000

Live

http://apmhost/ApmServer/#/metrics?fa=%5B%5D&ep=0&m=L&l=ATC&u=UNFWEnterprise%20Team%20Center&cht=0&chs=1&cha=0&selectedMetrics=%5B%22SuperDomain%7CAPMHost%7CCommon%7CAgent%7CMonitored%20Servers%7CApache%20Web%20Servers%7CApache%7CAPMHost%7CAvailability:Availability%20Status%22%5D&range=5

In historic mode, it specifies the timestamp based on the client, but in live mode, it is using the range on the server.
So in live mode, the UI gets the charts data but with an offset that is outside the current time window.
Resolution:
Check the system time of the Enterprise Manager and make sure the times are synchronised, particularly to compare with requests from the client machine.