APIs not appearing in dropdown list to add to an application

Document ID : KB000005328
Last Modified Date : 14/02/2018
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Issue:

When adding API(s) to an Application in the CA API Developer portal, the dropdown list box where the API is selected shows an incomplete list of the available APIs. The list of APIs is sorted alphabetically, so the missing APIs will all be ones that would appear after the existing listed APIs when alpha sorted.

To get to the 'Add APIs' field where this problem presents itself: From the API Developer portal dashboard, select Organizations, then Applications from the left menu. Edit an application by selecting the gear icon, then Edit. Select the API Management tab and scroll to the bottom to see the 'Choose an API' dropdown list box.

Cause:

The list of APIs appearing in the 'Add APIs' dropdown listbox is limited to 999 entries by default

Resolution:

Connect to the CA API Developer Portal host through ssh. Edit(increase) the pageSize="999" entries in the following XML files: 

     /sitebuilder/installed/pagerules/applications/internal-applications.xml 

     /sitebuilder/installed/pagerules/applications/developer-applications.xml 

A restart of the portal server and clearing the local browser cache will likely be required for the changes to fully take effect.