APIs are not visible on the portal

Document ID : KB000102745
Last Modified Date : 20/06/2018
Show Technical Document Details
Issue:
When you login in portal and click on API's under dashboard the list of API's will not populate
Environment:
CA Api Developer Portal 3.5
Cause:
JDBC connection is broken and you will see below errors in catalina.out

INFO (BackgroundLRSWrapper:) - [LRSWrapper general] -- connected to https://<gateway fqdn>:8443/portalman/1/apis using GET
DEBUG (BackgroundLRSWrapper:) - [LRSWrapper general] -- <Error>
<Code>500</Code>
<Detail>Invalid Operation</Detail>
</Error>

You will see the same error when you try to access https://<gateway fqdn>:8443/portalman/1/apis from browser as well
Resolution:
1. If you have implemented the steps mentioned in this KB article "KB000077239" https://comm.support.ca.com/kb/install-new-portalman-in-api-portal-cr3-and-above/kb000077239 at line 355 you will find jdbc connection

2. If this JDBC connection is broken you will see Error Code 500

3. From policy manager navigate to the JDBC connection local and click on test and see if it is working and most probably it will fail

4. Check if the JDBC is pointing to correct DB and has other properties entered correctly.