API Gateway with Monthly Platform Patch (MPP) will fail its upgrade

Document ID : KB000118454
Last Modified Date : 25/10/2018
Show Technical Document Details
Issue:
Unable to install the Gateway Release Upgrade Patches if the Monthly Platform Patch (MPP) has been installed since its March 2018 release.
Environment:
All form factors of the CA API Gateway with MPP installed since March
Cause:
A recent change in the Monthly Platform Patch (MPP) was made to keep multiple versions of kernel RPMs to allow for rollback. This change voids some expectations in the Gateway Release Upgrade Platform patch and will cause the upgrade to fail.
Resolution:
Prior to upgrading to any minor or major release, ensure that you have installed CA_API_PlatformUpdate_64bit_vKernel-2018-10-05.L7P. This patch removes non-running kernel RPMs and will allow for the Gateway Release Upgrade Patch to execute successfully.
Additional Information:
This issue has been resolved in the CA API Gateway 9.4.00 version, which will be available shortly.