API Gateway Software Form Installer Support on RHEL 7

Document ID : KB000109314
Last Modified Date : 02/08/2018
Show Technical Document Details
Question:
Customer installed API Gateway v9.3 on RHEL6 due to SSO SDK is not compatible with RHEL7. Please see the doc on CA site ( Even though the Software Gateway may be deployed in RHEL 7 environments, this version of the CA Single Sign-On SDK is not compatible with RHEL 7.) https://docops.ca.com/ca-api-gateway/9-3/en/security-configuration-in-policy-manager/tasks-menu-security-options/manage-ca-single-sign-on-configurations/install-the-ca-single-sign-on-sdk-for-software-gateways

We need to know when API Gateway with SSO SDK is available on RHEL7?
Environment:
APIM Gateway 9.3 running on RHEL7
Integration with CA SSO Authentication and authorization 

The API Gateway 9.3 deploy on CA SSO SDK R12.52 SP1 CR04 with APIM 9.3 GW
The agent side CA SSO SDK was not certified for Red Hat 7 until R12.52 SP01 CR05 – one CR off
 
Gateway 9.3 uses Agent side SSO SDK R12.52 SP01 CR04
 
/opt/CA/sdk/install_config_info
[root@mcqst02-ssg930-fips install_config_info]# more ca-sdk-version.info
ProductName=CA SiteMinder SDK
FullVersion=12.52.104.2032
Location=/opt/CA/sdk

 
Answer:
The work is scheduled to be done by end of year 2018, Enhancement number F68869: CA SSO Support on RHEL7CentOS7