API-1018 Error when attempting to replace a role or update allocation data in Clarity PPM New UX

Document ID : KB000118018
Last Modified Date : 25/03/2019
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Issue:
Receive Error "API-1018:Unable to Process the Request. Refer to error code for more details" in multiple Clarity PPM New User Experience (UX) fly out screens. Error can be seen when attempting to replace a role with a resource, updating allocation start or finish dates or Allocation %.
  • Another symptom that may be seen due to this issue is a "Could not load project" error message when trying to access a project in the New UX. Note: You may only see one of the above symptoms
Issue happens in multiple browsers (Including Chrome and Mozilla). 

Symptom 1:

Steps to Reproduce the API-1018 error when replacing a role with a resource
(Issue also happens if attempting to update a resource's Allocation Start/Finish Dates or Allocation %)


1. Go to the staffing page in the New UX 
2. In the Requests portlet, expand a role that is added to one or more projects 
3. Click on a project beneath the role 
5. Change Allocate to a resource 
6. Click Confirm Allocation 

Expected Results: Role is replaced successfully without any error 
Actual Results: Receive an API Error: API-1018 and role is not replaced with the resource 

Symptom 2:

Steps to Reproduce the "Could not load project" issue:
  1. Log in to the New UX in PPM
  2. Go to Projects and click on any project
Expected Results: The project is access successfully without putting in the user name and password
Actual Results: A message appears in the top center "Could not load project" and you are asked to log in again to PPM
Cause:
This issue is caused by DE45213 
Resolution:
This issue is fixed in Clarity 15.6 and 15.5.1 patch 1.
Additional Information:
Reference KB000005850 - When attempting to view a Status Report in the new UX, Receive Error "API-1005 : Attribute(s) 'pdfFile'.." or "Could not load project status report"