Apache 2.4 crashing on RHEL with Web Agent R12.52 SP1 CR09

Document ID : KB000115843
Last Modified Date : 10/10/2018
Show Technical Document Details
Issue:
We have an issue with Web Agent R12.52 SP1 CR09 and Apache. Our Apache server is giving cores and crashing, then it stops working. Apache version is 2.4.6 64-bit.

When the crash happens, then Apache and CA SSO stop working, and once the Apache web server is restarted, everything starts working again until after some time it happens the same again.

Stack seen in core dump:
(gdb) #0 0x00007fe32b54c5f7 in raise () from /lib64/libc.so.6 
#1 0x00007fe32b54dce8 in abort () from /lib64/libc.so.6 
#2 0x00007fe3210fb9d5 in __gnu_cxx::__verbose_terminate_handler() () from /lib64/libstdc++.so.6 
#3 0x00007fe3210f9946 in ?? () from /lib64/libstdc++.so.6 
#4 0x00007fe3210f9973 in std::terminate() () from /lib64/libstdc++.so.6 
#5 0x00007fe3210f9b93 in __cxa_throw () from /lib64/libstdc++.so.6 
#6 0x00007fe32114e757 in std::__throw_logic_error(char const*) () from /lib64/libstdc++.so.6 
#7 0x00007fe32115a5a1 in char* std::string::_S_construct<char const*>(char const*, char const*, std::allocator<char> const&, std::forward_iterator_tag) () from /lib64/libstdc++.so.6 
#8 0x00007fe32115a958 in std::basic_string<char, std::char_traits<char>, std::allocator<char> >::basic_string(char const*, std::allocator<char> const&) () from /lib64/libstdc++.so.6 
#9 0x00007fe32321d472 in ModifyLogTransaction(request_rec*) () from /webagent/bin/libmod_sm24.so 
#10 0x00007fe32d046f40 in ap_run_log_transaction (r=r@entry=0x7fe2fc0473c0) at protocol.c:2334 
#11 0x00007fe32d0481b3 in ap_read_request (conn=conn@entry=0x7fe31403d778) at protocol.c:1286 
#12 0x00007fe32d071328 in ap_process_http_sync_connection (c=0x7fe31403d778) at http_core.c:192 
#13 ap_process_http_connection (c=0x7fe31403d778) at http_core.c:251 
#14 0x00007fe32d068a30 in ap_run_process_connection (c=c@entry=0x7fe31403d778) at connection.c:42 
#15 0x00007fe32d068f88 in ap_process_connection (c=c@entry=0x7fe31403d778, csd=csd@entry=0x7fe31403d560) at connection.c:226 
#16 0x00007fe32419986b in process_socket (bucket_alloc=0x7fe2fc0008e8, my_thread_num=2, my_child_num=1, sock=0x7fe31403d560, 
p=0x7fe31403d4d8, thd=0x7fe32d9046c8) at worker.c:631 
#17 worker_thread (thd=0x7fe32d9046c8, dummy=<optimized out>) at worker.c:992 
#18 0x00007fe32bae3dc5 in start_thread () from /lib64/libpthread.so.0 
#19 0x00007fe32b60d1cd in clone () from /lib64/libc.so.6 


How can we solve this issue?
Environment:
Web Agent R12.52 SP1 CR09 64-bit on Apache 2.4.x 64-bit
Cause:

 
Resolution:
This issue is fixed in R12.52 SP1 CR10, please upgrade to this version when available to solve the issue.

If it is not released yet, you may open a Support case asking for a NIN with reference DE384842/DE386658, until CR10 is available.