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Animations being backlogged
Document ID :
KB000116964
Last Modified Date :
04/10/2018
Show Technical Document Details
Products
CA Service Desk Manager
Releases
CA Service Desk Manager:Release:12.9
CA Service Desk Manager:Release:17.1
CA Service Desk Manager:Release:17.0
Components
SERVICE DESK MANAGER:USRD
Issue:
CA Service Desk administrator is seeing the message below in stdlog:
38005 animations pending from now to 10/03/2018 19:00:30; 37993 backlogged
Environment:
CA Service Desk 17.1
CA Service Desk 17.0
CA Service Desk 14.1
Cause:
Animations are processed by the
Animator (animator_nxd)
process.
See below the animator process overview:
Manages events (animators)
Fetches Animator table
Gets
domset
based on interval time
Handles the queue of animators
Adds and deletes animators from the database
When Animator (animator_nxd) is not working properly, animations start being backlogged and a lot of side-effect can occur e.g. delayed events, auto-closing not working as expected, CA Service Management not sending processes to CA IT Process Automation.
Resolution:
For simple conventional mode installation, sometimes restarting all servers can fix this issue. It is useful when
animator_nxd
stopped processing events because of communication issues between CA Service Desk processes. For more complex situations, consider adding a dedicated
domsrvr
to the
Animator (animator_nxd)
process.
See references below:
Creating a dedicated Domsrvr to the Animator Process for CA Service Desk Manager (SDM) r12.9 and r14.1 in Conventional Mode
Creating a dedicated Domsrvr to the Animator Process for CA Service Desk Manager (SDM) r12.9 r14.1 and r17.x in Advanced Availability (AA) Mode
Reference for troubleshooting Animators:
pdm_logstat -f animator_nxd.c 300
pdm_extract Animator
pdm_extract Attached_Events
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