An error occurred while creating a subprocess in the processing server. [RCIRAS0603]

Document ID : KB000029135
Last Modified Date : 14/02/2018
Show Technical Document Details

Clients that have boxi installed on Red Hat 6.x Operating systems may receive the following error when a user attempts to run any 

report from within infoview or the CMC:

 

An error occurred while creating a subprocess in the processing server. [RCIRAS0603]

 

CA has determined this to be a problem with the BOXI application and engaged SAP 

support directly to address this situation.  SAP has determined this to be a problem

on their end and provided the following SAP KB:

 

==========================================================

SAP KB 2098659

 

2098659 - "An error occurred while creating a subprocess in the processing

server. [RCIRAS0603]" error occurs after applied X11 client libraries

security update on Redhat Linux 6

 

 

Symptom

" Crystal Reports 2011/2013 Processing Server fails to create child

processes after applied X11 client libraries security update on Redhat

Linux 6

" "An error occurred while creating a subprocess in the processing server.

[RCIRAS0603]" error occurs when viewing the Crystal Reports in InfoView/BI

Launchpad or CMC

 

Other Terms

Environment:

" SAP BusinessObjects Enterprise XI 3.1 SP5 (Full Build) or above

" SAP BusinessObjects Business Intelligence Platform 4.1

" Red Hat Linux 6

" X11 client libraries security, bug fix, and enhancement update installed

Steps to Duplicate:

1. Install X11 client libraries security, bug fix, and enhancement update.

CLA-2014:1436 Moderate: X11 client libraries security, bug fix, and

enhancement update

libXext-1.3.2-2.1.el6-x86_64

libXcursor-1.1.14-2.1.el6-x86_64

libXxf86dga-1.1.4-2.1.el6-x86_64

libXv-1.0.9-2.1.el6-x86_64

libXi-1.7.2-2.2.el6-i686

libX11-1.6.0-2.2.el6-x86_64

libXrender-0.9.8-2.1.el6-x86_64

libXfixes-5.0.1-2.1.el6-x86_64

libX11-devel-1.6.0-2.2.el6-x86_64

libXext-devel-1.3.2-2.1.el6-x86_64

libXtst-1.2.2-2.1.el6-x86_64

libXxf86vm-1.1.3-2.1.el6-x86_64

libXp-1.0.2-2.1.el6-x86_64

libXt-1.1.4-6.1.el6-x86_64

libXext-1.3.2-2.1.el6-i686

libXext-devel-1.3.2-2.1.el6-i686

libXt-1.1.4-6.1.el6-i686

libX11-common-1.6.0-2.2.el6-noarch

libXi-1.7.2-2.2.el6-x86_64

libXrandr-1.4.1-2.1.el6-x86_64

libXinerama-1.1.3-2.1.el6-x86_64

libX11-1.6.0-2.2.el6-i686

libXtst-1.2.2-2.1.el6-i686

 

2. Log on to InfoView/BI Launchpad or Central Management Console (CMC).

 

3. Open any Crystal Report to view, the error occurs.

 

Solution

"  The issue has been forwarded to SAP Development for further investigation.

"  X11 client libraries security update was released in October 2014 which

is too new for our products, the development team didn't test with this new

update.

" So far one of our components doesn't work with this new security update,

so the current workaround is uninstalling this update.

 

=======================================================

 

If your linux server has installed this X11 client security update and your experiencing the

reported problem we ask that you downgrade any of the above listed packages

and see if that addresses the problem while SAP continues to develop a fix

to address the situation.

 

 

For instance if you had the following packages installed

 

libX11-1.6.0-2.2.el6.i686

libX11-1.6.0-2.2.el6.x86_64

libX11-common-1.6.0-2.2.el6.noarch

libX11-devel-1.6.0-2.2.el6.x86_64

libXcursor-1.1.14-2.1.el6.x86_64

libXext-1.3.2-2.1.el6.i686

libXext-1.3.2-2.1.el6.x86_64

libXext-devel-1.3.2-2.1.el6.i686

libXext-devel-1.3.2-2.1.el6.x86_64

 

You can execute the following command to downgrade those packages:

 

yum downgrade libX{11,11-common,11-devel,cursor,ext,ext-devel}

 

Reboot the server and see if the situation is addressed.