Error: SDM Migration failed with exitCode : 2 during upgrade to SDM 14.1

Document ID : KB000103190
Last Modified Date : 25/06/2018
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Issue:
When upgrading to SDM 14.1, the installation fails at step 4, "Migrating CA Service Desk Manager" with error "Error: SDM Migration failed with exitCode : 2"

You may see the following errors in the install.log:
2018/06/23 12.00.56.901 ERROR [DeployThread: Upgrading CA Service Desk Manager] [FileUtilities] Exception occured during properties file update. 
2018/06/23 12.00.56.901 ERROR [DeployThread: Upgrading CA Service Desk Manager] [FileUtilities] E:\SERVIC~1\CA\SERVIC~1\SDUninstall\SDUninstall.lax (The system cannot find the path specified) class java.io.FileNotFoundException 
2018/06/23 12.00.56.901 ERROR [DeployThread: Upgrading CA Service Desk Manager] [FileUtilities] Could not delete original file:E:/SERVIC~1/CA/SERVIC~1\SDUninstall\SDUninstall.lax 
2018/06/23 12.00.56.901 ERROR [DeployThread: Upgrading CA Service Desk Manager] [FileUtilities] Important: Uninstallation might be silent. 


2018/06/23 12.01.59.447 DEBUG [stderr( E:\SERVIC~1\CA\SERVIC~1\bin\pdm_perl.exe):Thread-30] [MigrateSDM] Can't open perl script "migrate_to_r14_1.pl": No such file or directory 
2018/06/23 12.01.59.704 INFO [DeployThread: Migrating CA Service Desk Manager] [ActiveProcessHolder] Exit Monitor. Process ID (PID): 4996 
2018/06/23 12.01.59.704 INFO [DeployThread: Migrating CA Service Desk Manager] [ProcessUtilities] Process E:\SERVIC~1\CA\SERVIC~1\bin\pdm_perl.exe completed with exit code 2 
2018/06/23 12.01.59.704 DEBUG [DeployThread: Migrating CA Service Desk Manager] [ProgressPage] ProgressPage - Task Changed Migrating CA Service Desk Manager 
2018/06/23 12.01.59.704 DEBUG [DeployThread: Migrating CA Service Desk Manager] [ProgressPage] Task State Changed. TaskID: task.migrate_sdm,Migrating CA Service Desk Manager, Old State: running, New State:failed 
2018/06/23 12.01.59.704 INFO [DeployThread: Migrating CA Service Desk Manager] [DeployThread] Saving task 'task.migrate_sdm' status to DB .... 
2018/06/23 12.01.59.705 INFO [DeployThread: Migrating CA Service Desk Manager] [DatabasePersister] Saving component install state to database. 
2018/06/23 12.01.59.705 DEBUG [DeployThread: Migrating CA Service Desk Manager] [DatabasePersister] Insert/Update Parameters: productCode (1); currVersion (14.1); status(failed); packageId(task.migrate_sdm) 
2018/06/23 12.01.59.705 INFO [Thread-28] [ProgressUpdateMigrateSDM] Waiting for migration log to be available. retry 1 of 50 
Cause:
Not having enough disk space may cause the install to fail here with the above errors recorded in the logs. Although the install.log may indicate that there is enough disk space with a message similar to the following:

2018/06/23 11.54.41.799 DEBUG [AWT-EventQueue-0] [DiskSpacePrereqValidator] Available Disk Space: 79263, Required Disk Space: 5120
2018/06/23 11.54.41.800 INFO  [AWT-EventQueue-0] [DiskSpacePrereqValidator] SUCCESS: Enough Diskspace available. Available Disk Space: 79263, Required Disk Space: 5120

This does not consider the size of your current Service Desk Directory. 
Resolution:
Run the setup.exe under the products directory of the install media (E:\products\SDM) rather than the root of the install media then go into 3. Product Details and click on CA Service Desk Manager. After clicking next through the two pages of information you will reach a screen where you can see the required and available disk space and as you can see in the image below, there is a shortage of disk space. You will either have to add more disk space or free up some space in the Service Desk Folder. Once you pass this disk space check, you can cancel this installer and retry the installation from the root of the install media again.

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