All Tasks are not scheduled anymore after a calendar modification

Document ID : KB000084644
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Affects Release version(s): 5

Error Message :
In the "universe.log" file:
#########
Calendar not in range
#########

After the modification of the General Calendar, the Tasks are not scheduled/launched anymore.
Environment:
OS: All
Cause:
Cause type:
Configuration
Root Cause: The validity date defined in the Task is defined at a date prior to the start date of the modified Calendar.
Resolution:
First move all Validity Dates forward (to e.g. the first day of the current year).
Now, set the start date to the beginning of the year and extend the end date of the Calendar as required.


Fix Status: No Fix

Additional Information:
Workaround :
Extend the start date of the Calendar to a year before the oldest Validity Date of all the Tasks.
Now check that the Tasks are scheduled again.