All JWPs stuck for 10 minutes, no login, no search, etc. possible

Document ID : KB000092341
Last Modified Date : 03/05/2018
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Issue:
The issue happens sporadically. All JWP processes on are frozen. Following error message appears in all JWP logs:

20180327/084531.619 - 105    U00003407 Client connection '219' from 'xxx.xxx.xxx.xxx:xxxx' has logged off from the Server.
20180327/084531.663 - 107    U00003525 UCUDB: ===> 'TIMEOUT: 600 seconds, processing continues' 
20180327/084531.664 - 107    U00003434 Server routine  'HashMap/USER_ADD' required '10' minutes and '0' seconds for processing. 

During that time, no login (using kerberos, ldaps, ...), no process monitoring and no search was possible within the AWI. The lucene index was not updated. The situation lasts for about 10 minutes and then system resumes normal operation.
Environment:
It affects systems with the following version or older versions:
  • Component:
    AE Server, Initialdata and Automic.Web.Interface

    Component Version
  • Automation Engine 12.1.1
Cause:
A problem has been fixed where JWPs timed out when ILM is used. During ILM actions, processing is stopped. If there are other requests to a JWP (for example a user logon) while processing is stopped, the JWP does not continue and runs in a timeout (ILM_TIMEOUT, default 10 minutes). Processing in a JWP continues after the ILM timeout.
Resolution:
The system freeze is resolved by the system itself after about 10 Minutes. No further corrective actions are necessary.

To avoid such situations, please install one of the fixed versions or a newer one:

Component:
AE Server, Initialdata and Automic.Web.Interface

Component Version
  • Automation Engine 12.2.0
  • Automation Engine 12.1.2